2.0 Compatible?

Feb 17, 2009 at 8:30 PM
Will this work with SyntaxHighlighter 2.0?
Coordinator
Feb 19, 2009 at 2:17 AM
Thank you for your discussion.

I didn't know new SyntaxHighlighter. I want to upgrade this plugin. However, it is not yet determinded.
SyntaxHighlighter 2.0 is compatible with 1.5. I think that currentry plugin version works SyntaxHighlighter 1.5  features with SyntaxHighlighter 2.0(but I don't try yet.)


Feb 25, 2009 at 5:09 PM
I also would like to see a new version of the plugin which is 2.0 compatible.
Feb 26, 2009 at 7:19 AM
I had a look at the source code this morning, and if I understand it right, all that needs to be done for basic 2.0 compatiblity is to modify the GetPublishHtml method in SyntaxHighligter.vb.

Simply change the generated HTML syntax to match the new 2.0 syntax and everything should be fine :-)
Jul 6, 2009 at 6:56 AM

I have modified your project a bit to support 2.0 compatiblity. It uses c#. You can find the plugin at http://blog.prabir.me/post/Windows-Live-Writer-Syntax-Highlighter.aspx.

Thanks for the project.